Jump to content
rocketman74

EAP-1750H firmware update issues with v2.0.5

Recommended Posts

I am trying to upgrade two of my EAP-1750H access points to the new v2.0.5 to fix the Krack vulnerability, Both devices are currently on version 2.0.361.

 

Upon downloading the file, unzipping it and selecting the bin file in the AP's firmware update tool I keep getting the following error on both devices. I downloaded the North American/FCC version.  

Firmware upgrade has failed for unexpected reasons. Please make sure your firmware is valid.

 

What am I doing wrong? Thanks in advance for your help. 

Share this post


Link to post
Share on other sites

Presumably, 2.0.5 is a newer version than 2.0.361, correct? The date for 2.0.5 on the EnGenius website said October or November 2017 when I pulled it yesterday. 

 

If 2.0.5 isn't the latest version, what should I install for my AP devices in the United States? 

Edited by rocketman74

Share this post


Link to post
Share on other sites

Did you download it from www.engeniusnetworks.com? The release date for the 2.0.5 is 10-17-2014. 

The latest firmware is still the 2.0.361.

Share this post


Link to post
Share on other sites

Thanks Mike. I see that date now for 2.0.5. It must have thrown me off last night when I was looking as the year part of the date was up front and the day part of the date was the last number.

 

I'll keep an eye out for a newer version when the Krack vulnerability has been assessed. Any idea when the next firmware version, including the Krack fix, will be released for this device?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.